]> git.pld-linux.org Git - packages/perl-Crypt-Random.git/blob - perl-Crypt-Random.spec
use generic url
[packages/perl-Crypt-Random.git] / perl-Crypt-Random.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    Random
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Crypt::Random - cryptographically secure, true random number generator
9 Summary(pl.UTF-8):      Crypt::Random - bezpieczny kryptograficznie, prawdziwy generator liczb losowych
10 Name:           perl-Crypt-Random
11 Version:        1.25
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5730c9d5acdd698790216d354ffb0513
18 Patch0:         %{name}-no_Class_Loader.patch
19 URL:            http://search.cpan.org/dist/Crypt-Random/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Math-Pari >= 2.001804
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Crypt::Random is an interface module to the /dev/random device found
30 on most modern Unix systems. The /dev/random driver gathers
31 environmental noise from various non-deterministic sources including
32 inter-keyboard timings and inter-interrupt timings that occur within
33 the operating system environment.
34
35 %description -l pl.UTF-8
36 Moduł Perla Crypt::Random stanowi interfejs do urządzenia /dev/random
37 znajdującego się w większości współczesnych systemów uniksowych.
38 Sterownik /dev/random gromadzi szum pochodzący z różnych
39 niedeterministycznych źródeł, włączając w to: przebiegi czasowe
40 klawiatury i przerwań występujące w systemie operacyjnym.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44 %patch0 -p1
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %attr(755,root,root) %{_bindir}/*
66 %{perl_vendorlib}/Crypt/Random.pm
67 %{perl_vendorlib}/Crypt/Random
68 #%%{perl_vendorlib}/Crypt/Random/Generator.pm
69 %{_mandir}/man3/*
This page took 0.119747 seconds and 3 git commands to generate.