]> git.pld-linux.org Git - packages/perl-Crypt-Primes.git/blob - perl-Crypt-Primes.spec
use generic url
[packages/perl-Crypt-Primes.git] / perl-Crypt-Primes.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    Primes
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Crypt::Primes - provable prime number generator suitable for cryptographic applications
9 Summary(pl.UTF-8):      Crypt::Primes - wiarygodny generator liczb pierwszych, nadający się do aplikacji kryptograficznych
10 Name:           perl-Crypt-Primes
11 Version:        0.50
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  041947b9645142615d687b89cf2e1a7b
18 URL:            http://search.cpan.org/dist/Crypt-Primes/
19 BuildRequires:  perl-Crypt-Random >= 0.33
20 BuildRequires:  perl-Math-Pari >= 2.001804
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Crypt::Primes module implements in pure Perl Ueli Maurer's algorithm
28 for generating large provable primes and secure parameters for
29 public-key cryptosystems. The generated primes are almost uniformly
30 distributed over the set of primes of the specified bitsize and
31 expected time for generation is less than the time required for
32 generating a pseudo-prime of the same size with Miller-Rabin tests.
33 Detailed description and running time analysis of the algorithm can be
34 found in Maurer's paper (Fast Generation of Prime Numbers and Secure
35 Public-Key Cryptographic Parameters, Ueli Maurer (1994)).
36
37 %description -l pl.UTF-8
38 Moduł Crypt::Primes jest czysto perlową implementacją algorytmu
39 generacji dużych wiarygodnych liczb losowych Ueli Maurera oraz
40 generacji bezpiecznych parametrów dla systemów kryptograficznych
41 korzystających z klucza publicznego. Wygenerowane liczby pierwsze są
42 rozłożone niemal jednostajnie w zbiorze liczb pierwszych o zadanym
43 rozmiarze bitowym a oczekiwany czas generacji jest krótszy niż dla
44 generacji liczb pseudo-pierwszych o tym samym rozmiarze za pomocą
45 testów Millera-Rabina. Szczegółowy opis i analizy czasowe algorytmu
46 można znaleźć z artykule Maurera (Fast Generation of Prime Numbers and
47 Secure Public-Key Cryptographic Parameters, Ueli Maurer (1994))
48
49 - wiarygodny generator liczb pierwszych, nadający się dla aplikacji
50   kryptograficznych.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %attr(755,root,root) %{_bindir}/*
75 %{perl_vendorlib}/Crypt/Primes.pm
76 %{_mandir}/man[13]/*
This page took 0.054243 seconds and 3 git commands to generate.