]> git.pld-linux.org Git - packages/perl-Crypt-PassGen.git/blob - perl-Crypt-PassGen.spec
- bcond fixes/porting
[packages/perl-Crypt-PassGen.git] / perl-Crypt-PassGen.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    PassGen
8 Summary:        Crypt::PassGen Perl module - generate a random password
9 Summary(pl):    Modu³ Perla Crypt::PassGen - generuj±cy losowe has³a
10 Name:           perl-Crypt-PassGen
11 Version:        0.04
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5ccb497f6e33680b22a0041e1f397a2a
18 Patch0:         %{name}-FHS.patch
19 BuildRequires:  perl-devel >= 5.6
20 BuildRequires:  perl-Storable
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  words
23 BuildConflicts: wordlist
24 Requires:       words
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides a single command for generating random password
30 that is close enough to a real word that it is easy to remember. It
31 does this by using the frequency of letter combinations in a language.
32
33 %description -l pl
34 Ten modu³ udostêpnia polecenie do generowania losowych hase³
35 zbli¿onych do prawdziwych s³ów na tyle, ¿e s± ³atwe do zapamiêtania.
36 U¿ywa do tego tablicy czêsto¶ci wystêpowania kombinacji liter w danym
37 jêzyku.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41 %patch0 -p1
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc ChangeLog README
61 %{perl_vendorlib}/Crypt/PassGen.pm
62 %{perl_vendorlib}/Crypt/PassGenWordFreq.dat
63 %{_mandir}/man3/*
This page took 0.060192 seconds and 4 git commands to generate.