]> git.pld-linux.org Git - packages/perl-Crypt-PassGen.git/blob - perl-Crypt-PassGen.spec
- formatting
[packages/perl-Crypt-PassGen.git] / perl-Crypt-PassGen.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    PassGen
8 Summary:        Crypt::PassGen Perl module - generate a random password
9 Summary(pl):    Modu³ Perla Crypt::PassGen - generuj±cy losowe has³a
10 Name:           perl-Crypt-PassGen
11 Version:        0.04
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5ccb497f6e33680b22a0041e1f397a2a
18 Patch0:         %{name}-FHS.patch
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  words
22 BuildConflicts: wordlist
23 Requires:       words
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides a single command for generating random password
29 that is close enough to a real word that it is easy to remember. It
30 does this by using the frequency of letter combinations in a language.
31
32 %description -l pl
33 Ten modu³ udostêpnia polecenie do generowania losowych hase³
34 zbli¿onych do prawdziwych s³ów na tyle, ¿e s± ³atwe do zapamiêtania.
35 U¿ywa do tego tablicy czêsto¶ci wystêpowania kombinacji liter w danym
36 jêzyku.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40 %patch0 -p1
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc ChangeLog README
60 %{perl_vendorlib}/Crypt/PassGen.pm
61 %{perl_vendorlib}/Crypt/PassGenWordFreq.dat
62 %{_mandir}/man3/*
This page took 0.093694 seconds and 4 git commands to generate.