]> git.pld-linux.org Git - packages/perl-Crypt-PassGen.git/blob - perl-Crypt-PassGen.spec
- should be ready for perl-5.8.0; release++
[packages/perl-Crypt-PassGen.git] / perl-Crypt-PassGen.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    PassGen
8 Summary:        Crypt::PassGen Perl module - generate a random password
9 Summary(pl):    Modu³ Perla Crypt::PassGen - generuj±cy losowe has³a
10 Name:           perl-Crypt-PassGen
11 Version:        0.03
12 Release:        2
13 License:        Artistic or GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 Patch0:         %{name}-FHS.patch
17 BuildRequires:  perl >= 5.6
18 BuildRequires:  perl-Storable
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  words
21 BuildConflicts: wordlist
22 Requires:       words
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a single command for generating random password
28 that is close enough to a real word that it is easy to remember. It
29 does this by using the frequency of letter combinations in a language.
30
31 %description -l pl
32 Ten modu³ udostêpnia polecenie do generowania losowych hase³
33 zbli¿onych do prawdziwych s³ów na tyle, ¿e s± ³atwe do zapamiêtania.
34 U¿ywa do tego tablicy czêsto¶ci wystêpowania kombinacji liter w danym
35 jêzyku.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor 
44 %{__make}
45 %{!?_without_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog README
59 %{perl_vendorlib}/Crypt/PassGen.pm
60 %{perl_vendorlib}/Crypt/PassGenWordFreq.dat
61 %{_mandir}/man3/*
This page took 0.075433 seconds and 4 git commands to generate.