]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-RSA.git/blob - perl-Crypt-OpenSSL-RSA.spec
db13e66a21513576c2c3f0c24329f245d7ec484d
[packages/perl-Crypt-OpenSSL-RSA.git] / perl-Crypt-OpenSSL-RSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    OpenSSL-RSA
8 Summary:        Crypt::OpenSSL::RSA - RSA encoding and decoding, using the OpenSSL libraries
9 Summary(pl.UTF-8):      Crypt::OpenSSL::RSA - kodowanie i dekodowanie RSA przy użyciu OpenSSL
10 Name:           perl-Crypt-OpenSSL-RSA
11 Version:        0.30
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  10bca2fc6d0ba1aa329f227424ae87d5
18 URL:            http://search.cpan.org/dist/Crypt-OpenSSL-RSA/
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Crypt-OpenSSL-Random
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Crypt::OpenSSL::RSA provides the ability to RSA encrypt strings which
29 are somewhat shorter than the block size of a key.  It also allows for
30 decryption, signatures and signature verification.
31
32 %description -l pl.UTF-8
33 Moduł Crypt::OpenSSL::RSA udostępnia możliwość kodowania algorytmem
34 RSA łańcuchów, które są krótsze niż rozmiar bloku klucza. Pozwala
35 także na odszyfrowywanie oraz weryfikację podpisów.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/Crypt/OpenSSL/RSA.pm
62 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA
63 %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/*.al
64 %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/autosplit.ix
65 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/*.so
66 %{_mandir}/man3/Crypt::OpenSSL::RSA.3pm*
This page took 0.03972 seconds and 2 git commands to generate.