]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-RSA.git/blob - perl-Crypt-OpenSSL-RSA.spec
78d1d62771dfd44096f586532ad67240d25c2187
[packages/perl-Crypt-OpenSSL-RSA.git] / perl-Crypt-OpenSSL-RSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-RSA
7 Summary:        Crypt::OpenSSL::RSA - RSA encoding and decoding, using the OpenSSL libraries
8 Summary(pl.UTF-8):      Crypt::OpenSSL::RSA - kodowanie i dekodowanie RSA przy użyciu OpenSSL
9 Name:           perl-Crypt-OpenSSL-RSA
10 Version:        0.30
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  10bca2fc6d0ba1aa329f227424ae87d5
17 URL:            http://search.cpan.org/dist/Crypt-OpenSSL-RSA/
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Crypt-OpenSSL-Random
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Crypt::OpenSSL::RSA provides the ability to RSA encrypt strings which
28 are somewhat shorter than the block size of a key.  It also allows for
29 decryption, signatures and signature verification.
30
31 %description -l pl.UTF-8
32 Moduł Crypt::OpenSSL::RSA udostępnia możliwość kodowania algorytmem
33 RSA łańcuchów, które są krótsze niż rozmiar bloku klucza. Pozwala
34 także na odszyfrowywanie oraz weryfikację podpisów.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Crypt/OpenSSL/RSA.pm
61 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA
62 %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/*.al
63 %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/autosplit.ix
64 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/RSA/*.so
65 %{_mandir}/man3/Crypt::OpenSSL::RSA.3pm*
This page took 0.039407 seconds and 2 git commands to generate.