]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-PKCS12.git/blob - perl-Crypt-OpenSSL-PKCS12.spec
- up to 0.6
[packages/perl-Crypt-OpenSSL-PKCS12.git] / perl-Crypt-OpenSSL-PKCS12.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-PKCS12
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Crypt::OpenSSL::PKCS12 - Perl extension to OpenSSL's PKCS12 API
9 Name:           perl-%{pdir}-%{pnam}
10 Version:        0.6
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  910c0a01fa2458a1e33114ee1b5b9674
16 URL:            http://search.cpan.org/dist/%{pdir}-%{pnam}/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl(Module::Install) >= 1.12
20 %if %{with tests}
21 BuildRequires:  perl-Pod-Coverage >= 0.19
22 BuildRequires:  perl-Test-Pod-Coverage >= 1.08
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This implements a small bit of OpenSSL's PKCS12 API.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 rm -rf inc/Module/Install inc/Module/Install.pm
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make} \
38         CC="%{__cc}" \
39         OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__make} pure_install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README TODO
54 %{perl_vendorarch}/%{pdir}/OpenSSL/*.pm
55 %dir %{perl_vendorarch}/auto/%{pdir}/OpenSSL/PKCS12
56 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/OpenSSL/PKCS12/*.so
57 %{_mandir}/man3/*
This page took 0.079667 seconds and 3 git commands to generate.