]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-DSA.git/blob - perl-Crypt-OpenSSL-DSA.spec
21ef8d4dfd6ad3ff00985fcd91a552356ac08daa
[packages/perl-Crypt-OpenSSL-DSA.git] / perl-Crypt-OpenSSL-DSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    OpenSSL-DSA
8 Summary:        Crypt::OpenSSL::DSA - Digital Signature Algorithm using OpenSSL
9 Summary(pl.UTF-8):      Crypt::OpenSSL::DSA - algorytm DSA używający OpenSSL
10 Name:           perl-Crypt-OpenSSL-DSA
11 Version:        0.14
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  61d06e8fe9c12e96743989ff13c7ea73
18 URL:            http://search.cpan.org/dist/Crypt-OpenSSL-DSA/
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BuildRequires:  openssl-tools
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  which
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Crypt::OpenSSL::DSA implements the DSA (Digital Signature Algorithm)
28 signature verification system.
29
30 %description -l pl.UTF-8
31 Moduł Crypt::OpenSSL::DSA jest implementacją systemu weryfikacji
32 podpisów DSA (Digital Signature Algorithm).
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Crypt/OpenSSL/DSA/Signature.pod
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Crypt/OpenSSL/DSA.pm
61 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/DSA
62 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/DSA/DSA.so
63 %{_mandir}/man3/Crypt::OpenSSL::DSA*.3pm*
This page took 0.090843 seconds and 2 git commands to generate.