]> git.pld-linux.org Git - packages/perl-Crypt-OpenPGP.git/blob - perl-Crypt-OpenPGP.spec
use generic url
[packages/perl-Crypt-OpenPGP.git] / perl-Crypt-OpenPGP.spec
1
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    OpenPGP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Crypt::OpenPGP Perl module - pure Perl implementation of the OpenPGP standard
9 Summary(pl.UTF-8):      Moduł Perla Crypt::OpenPGP - czysto perlowa implementacja standardu OpenPGP
10 Name:           perl-Crypt-OpenPGP
11 Version:        1.06
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  21e5a1a046d6ec2c4ef86b5980dbb96f
18 URL:            http://search.cpan.org/dist/Crypt-OpenPGP/
19 BuildRequires:  perl-Crypt-DSA
20 BuildRequires:  perl-Crypt-RSA
21 BuildRequires:  perl-Data-Buffer >= 0.04
22 BuildRequires:  perl-Math-Pari
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 %if %{with tests}
26 BuildRequires:  perl-Compress-Zlib
27 BuildRequires:  perl-Crypt-Blowfish
28 BuildRequires:  perl-Crypt-CAST5_PP
29 BuildRequires:  perl-Crypt-DES_EDE3
30 BuildRequires:  perl-Crypt-IDEA
31 BuildRequires:  perl-Crypt-RIPEMD160
32 BuildRequires:  perl-Crypt-Rijndael
33 BuildRequires:  perl-Crypt-Twofish >= 2.00
34 BuildRequires:  perl-Digest-MD5
35 BuildRequires:  perl-Digest-SHA1
36 BuildRequires:  perl-MIME-Base64
37 %endif
38 Requires:       perl-Data-Buffer >= 0.04
39 Requires:       perl-Term-ReadKey
40 Conflicts:      perl-Crypt-Twofish < 2.00
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 This is Crypt::OpenPGP. It provides a pure-Perl implementation of the
46 OpenPGP standard, including support for all versions of PGP and GnuPG.
47 It needs at least one simmetric cipher Perl module (Crypt::DES_EDE3
48 for 3DES, Crypt::CAST5_PP for CAST5, Crypt::IDEA for IDEA,
49 Crypt::Blowfish for Blowfish, Crypt::Twofish >= 2.00 for Twofish or
50 Crypt;:Rijndael for Rijndael) and at least one digest Perl module
51 (Digest::MD5 for MD5, Digest::SHA1 for SHA1 or Crypt::RIPEMD160 for
52 RIPE-MD/160).
53
54 %description -l pl.UTF-8
55 To jest moduł Crypt::OpenPGP. Jest on czysto perlową implementacją
56 standardu OpenPGP, wraz ze wsparciem dla wszystkich wersji PGP i
57 GnuPG. Wymaga co najmniej jednego modułu Perla z implementacją szyfru
58 symetrycznego (Crypt::DES_EDE3 dla 3DES, Crypt::CAST5_PP dla CAST5,
59 Crypt::IDEA dla szyfru IDEA, Crypt::Blowfish dla szyfru Blowfish,
60 Crypt::Twofish >= 2.00 dla szyfru Twofish albo Crypt::Rijndale dla
61 szyfru Rijndael) oraz co najmniej jednego modułu z implementacją
62 funkcji skrótu (Digest::MD5 dla MD5, Digest::SHA1 dla SHA1 albo
63 Crypt::RIPEMD160 dla RIPE-MD/160).
64
65 %prep
66 %setup -q -n %{pdir}-%{pnam}-%{version}
67
68 %build
69 %{__perl} Makefile.PL </dev/null \
70         INSTALLDIRS=vendor
71 %{__make}
72
73 %{?with_tests:%{__make} test}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc Changes README
87 %{perl_vendorlib}/Crypt/OpenPGP.pm
88 %{perl_vendorlib}/Crypt/OpenPGP
89 %{_mandir}/man3/*
This page took 0.098767 seconds and 3 git commands to generate.