]> git.pld-linux.org Git - packages/perl-Crypt-OpenPGP.git/blob - perl-Crypt-OpenPGP.spec
04697fd2aa3d169484c596e3ab69ce47af22530d
[packages/perl-Crypt-OpenPGP.git] / perl-Crypt-OpenPGP.spec
1
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    OpenPGP
8 Summary:        Crypt::OpenPGP Perl module - pure Perl implementation of the OpenPGP standard
9 Summary(pl.UTF-8):      Moduł Perla Crypt::OpenPGP - czysto perlowa implementacja standardu OpenPGP
10 Name:           perl-Crypt-OpenPGP
11 Version:        1.06
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  21e5a1a046d6ec2c4ef86b5980dbb96f
18 BuildRequires:  perl-Crypt-DSA
19 BuildRequires:  perl-Crypt-RSA
20 BuildRequires:  perl-Data-Buffer >= 0.04
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  perl-Math-Pari
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 %if %{with tests}
25 BuildRequires:  perl-Compress-Zlib
26 BuildRequires:  perl-Crypt-Blowfish
27 BuildRequires:  perl-Crypt-CAST5_PP
28 BuildRequires:  perl-Crypt-DES_EDE3
29 BuildRequires:  perl-Crypt-IDEA
30 BuildRequires:  perl-Crypt-RIPEMD160
31 BuildRequires:  perl-Crypt-Rijndael
32 BuildRequires:  perl-Crypt-Twofish >= 2.00
33 BuildRequires:  perl-Digest-MD5
34 BuildRequires:  perl-Digest-SHA1
35 BuildRequires:  perl-MIME-Base64
36 %endif
37 Requires:       perl-Data-Buffer >= 0.04
38 Requires:       perl-Term-ReadKey
39 Conflicts:      perl-Crypt-Twofish < 2.00
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 This is Crypt::OpenPGP. It provides a pure-Perl implementation of the
45 OpenPGP standard, including support for all versions of PGP and GnuPG.
46 It needs at least one simmetric cipher Perl module (Crypt::DES_EDE3
47 for 3DES, Crypt::CAST5_PP for CAST5, Crypt::IDEA for IDEA,
48 Crypt::Blowfish for Blowfish, Crypt::Twofish >= 2.00 for Twofish or
49 Crypt;:Rijndael for Rijndael) and at least one digest Perl module
50 (Digest::MD5 for MD5, Digest::SHA1 for SHA1 or Crypt::RIPEMD160 for
51 RIPE-MD/160).
52
53 %description -l pl.UTF-8
54 To jest moduł Crypt::OpenPGP. Jest on czysto perlową implementacją
55 standardu OpenPGP, wraz ze wsparciem dla wszystkich wersji PGP i
56 GnuPG. Wymaga co najmniej jednego modułu Perla z implementacją szyfru
57 symetrycznego (Crypt::DES_EDE3 dla 3DES, Crypt::CAST5_PP dla CAST5,
58 Crypt::IDEA dla szyfru IDEA, Crypt::Blowfish dla szyfru Blowfish,
59 Crypt::Twofish >= 2.00 dla szyfru Twofish albo Crypt::Rijndale dla
60 szyfru Rijndael) oraz co najmniej jednego modułu z implementacją
61 funkcji skrótu (Digest::MD5 dla MD5, Digest::SHA1 dla SHA1 albo
62 Crypt::RIPEMD160 dla RIPE-MD/160).
63
64 %prep
65 %setup -q -n %{pdir}-%{pnam}-%{version}
66
67 %build
68 %{__perl} Makefile.PL </dev/null \
69         INSTALLDIRS=vendor
70 %{__make}
71
72 %{?with_tests:%{__make} test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc Changes README
86 %{perl_vendorlib}/Crypt/OpenPGP.pm
87 %{perl_vendorlib}/Crypt/OpenPGP
88 %{_mandir}/man3/*
This page took 0.088036 seconds and 2 git commands to generate.