]> git.pld-linux.org Git - packages/perl-Crypt-Noekeon.git/blob - perl-Crypt-Noekeon.spec
- release 3
[packages/perl-Crypt-Noekeon.git] / perl-Crypt-Noekeon.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Noekeon
8 Summary:        Crypt::Noekeon - Crypt::CBC-compliant block cipher
9 Summary(pl.UTF-8):      Crypt::Noekeon - szyfr blokowy kompatybilny z Crypt::CBC
10 Name:           perl-Crypt-Noekeon
11 Version:        1.0.2
12 Release:        3
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  51fc0d4486e2f98cf433df4cf6c4dc6a
17 URL:            http://search.cpan.org/dist/Crypt-Noekeon/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Noekeon is a 128-bit key, 128-bit block cipher designed by Joan
24 Daemen, Michael Peeters, Vincent Rijmen, and Gilles Van Assche.
25 Noekeon was submitted as a NESSIE candidate. This module supports
26 the Crypt::CBC interface.
27
28 %description -l pl.UTF-8
29 Noekeon jest 128-bitowym szyfrem blokowym ze 128-bitowym kluczem,
30 opracowanym przez Joan Daemen, Michaela Peetersa, Vincenta Rijmena
31 i Gillesa Van Assche. Noekeon został zgłoszony jako kandydat do
32 NESSIE. Ten moduł obsługuje interfejs Crypt::CBC.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 cd examples
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54 for f in * ; do
55         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
56                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
57 done
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorarch}/Crypt/Noekeon.pm
66 %dir %{perl_vendorarch}/auto/Crypt/Noekeon
67 %{perl_vendorarch}/auto/Crypt/Noekeon/Noekeon.bs
68 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Noekeon/Noekeon.so
69 %{_mandir}/man3/*
70 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.055589 seconds and 3 git commands to generate.