]> git.pld-linux.org Git - packages/perl-Crypt-Misty1.git/blob - perl-Crypt-Misty1.spec
98ad37005a9cf990e55d2e8e422ca5c46a1a98f2
[packages/perl-Crypt-Misty1.git] / perl-Crypt-Misty1.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Misty1
7 Summary:        Crypt::Misty1 - Crypt::CBC-compliant block cipher
8 Summary(pl.UTF-8):      Crypt::Misty1 - szyfr blokowy kompatybilny z Crypt::CBC
9 Name:           perl-Crypt-Misty1
10 Version:        1.1.3
11 Release:        15
12 License:        GPL v2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  ca9e4ad4db7b249751731a35cae5f9bc
16 URL:            http://search.cpan.org/dist/Crypt-Misty1/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Misty1 is a 64-bit symmetric block cipher with a 128-bit key. It was
23 developed by Mitsuru Matsui, and is described in the paper "New Block
24 Encryption Algorithm MISTY" and in RFC 2994. In January of 2000, the
25 3GPP consortium selected a variant of Misty1, dubbed as KASUMI (the
26 Japanese word for "misty"), as the mandatory cipher in W-CDMA. This
27 module supports the Crypt::CBC interface.
28
29 %description -l pl.UTF-8
30 Misty1 to 64-bitowy symetryczny szyfr blokowy ze 128-bitowym kluczem.
31 Został opracowany przez Mitsuru Matsui i opisany w dokumencie "New
32 Block Encryption Algorithm MISTY" oraz w RFC 2994. W styczniu 2000
33 konsorcjum 3GPP wybrało wariant Misty1 pod nazwą KASUMI (japoński
34 odpowiednik słowa "misty") jako obowiązkowy szyfr w W-CDMA. Ten
35 moduł obsługuje interfejs Crypt::CBC.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 cd examples
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 for f in * ; do
58         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
59                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
60 done
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorarch}/Crypt/Misty1.pm
69 %dir %{perl_vendorarch}/auto/Crypt/Misty1
70 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Misty1/Misty1.so
71 %{_mandir}/man3/*
72 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.036551 seconds and 2 git commands to generate.