]> git.pld-linux.org Git - packages/perl-Crypt-Misty1.git/blob - perl-Crypt-Misty1.spec
- release 10 (by relup.sh)
[packages/perl-Crypt-Misty1.git] / perl-Crypt-Misty1.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Misty1
8 Summary:        Crypt::Misty1 - Crypt::CBC-compliant block cipher
9 Summary(pl.UTF-8):      Crypt::Misty1 - szyfr blokowy kompatybilny z Crypt::CBC
10 Name:           perl-Crypt-Misty1
11 Version:        1.1.3
12 Release:        10
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ca9e4ad4db7b249751731a35cae5f9bc
17 URL:            http://search.cpan.org/dist/Crypt-Misty1/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Misty1 is a 64-bit symmetric block cipher with a 128-bit key. It was
24 developed by Mitsuru Matsui, and is described in the paper "New Block
25 Encryption Algorithm MISTY" and in RFC 2994. In January of 2000, the
26 3GPP consortium selected a variant of Misty1, dubbed as KASUMI (the
27 Japanese word for "misty"), as the mandatory cipher in W-CDMA. This
28 module supports the Crypt::CBC interface.
29
30 %description -l pl.UTF-8
31 Misty1 to 64-bitowy symetryczny szyfr blokowy ze 128-bitowym kluczem.
32 Został opracowany przez Mitsuru Matsui i opisany w dokumencie "New
33 Block Encryption Algorithm MISTY" oraz w RFC 2994. W styczniu 2000
34 konsorcjum 3GPP wybrało wariant Misty1 pod nazwą KASUMI (japoński
35 odpowiednik słowa "misty") jako obowiązkowy szyfr w W-CDMA. Ten
36 moduł obsługuje interfejs Crypt::CBC.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 cd examples
57 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58 for f in * ; do
59         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
60                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
61 done
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorarch}/Crypt/Misty1.pm
70 %dir %{perl_vendorarch}/auto/Crypt/Misty1
71 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Misty1/Misty1.so
72 %{_mandir}/man3/*
73 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.055523 seconds and 3 git commands to generate.