]> git.pld-linux.org Git - packages/perl-Crypt-Khazad.git/blob - perl-Crypt-Khazad.spec
b245a0b42765ad54ff2470f7801127c7c845e864
[packages/perl-Crypt-Khazad.git] / perl-Crypt-Khazad.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Khazad
7 Summary:        Crypt::Khazad - Crypt::CBC-compliant block cipher
8 Summary(pl.UTF-8):      Crypt::Khazad - szyfr blokowy kompatybilny z Crypt::CBC
9 Name:           perl-Crypt-Khazad
10 Version:        1.0.3
11 Release:        15
12 License:        GPL v2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  f6908bf11cb780d455a8779a60ecc570
16 URL:            http://search.cpan.org/dist/Crypt-Khazad/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Khazad is a 128-bit key, 64-bit block cipher. Designed by Vincent
23 Rijmen and Paulo S. L. M. Barreto, Khazad is a NESSIE finalist for
24 legacy-level block ciphers. Khazad has many similarities with
25 Rijndael, and has an extremely high rate of diffusion. This module
26 supports the Crypt::CBC interface.
27
28 %description -l pl.UTF-8
29 Khazad to 64-bitowy szyfr blokowy ze 128-bitowym kluczem. Został
30 opracowany przez Vincenta Rijmena i Paulo S. L. M. Baretto. Khazad
31 jest finalistą NESSIE w kategorii spadkowych szyfrów blokowych.
32 Khazad ma wiele podobieństw do algorytmu Rijndael i ma bardzo
33 duży współczynnik dyfuzji. Ten moduł obsługuje interfejs Crypt::CBC.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 cd examples
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 for f in * ; do
56         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
57                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
58 done
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorarch}/Crypt/Khazad.pm
67 %dir %{perl_vendorarch}/auto/Crypt/Khazad
68 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Khazad/Khazad.so
69 %{_mandir}/man3/*
70 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.098509 seconds and 2 git commands to generate.