]> git.pld-linux.org Git - packages/perl-Crypt-Keys.git/blob - perl-Crypt-Keys.spec
6cf4c2bfe673976855131da89f9366b7352a6490
[packages/perl-Crypt-Keys.git] / perl-Crypt-Keys.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Keys
8 Summary:        Crypt::Keys Perl module - public and private key management
9 Summary(pl.UTF-8):      Moduł Perla Crypt::Keys - zarządzający kluczami publicznymi i prywatnymi
10 Name:           perl-Crypt-Keys
11 Version:        0.06
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  6c375a9d965ff86d3ae967b9e6bbaf36
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  perl-Convert-PEM >= 0.05
20 BuildRequires:  perl-Crypt-CBC >= 2.00
21 BuildRequires:  perl-Crypt-DES
22 BuildRequires:  perl-Data-Buffer
23 BuildRequires:  perl-Digest-MD5
24 BuildRequires:  perl-MIME-Base64
25 BuildRequires:  perl-Math-Pari >= 2.001804
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 Requires:       perl-Convert-PEM >= 0.05
28 Requires:       perl-Crypt-CBC >= 2.00
29 Requires:       perl-Math-Pari >= 2.001804
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Crypt::Keys is an on-disk key management system for public and private
35 keyfiles. The goal of the module is to be able to read and write
36 crypto keys in any encoding (eg. PEM, SSH, etc.). It can be used as a
37 front-end for key management, but it does not contain implementations
38 of any of the assymetric cryptography algorithms represented by the
39 keys that it manages. In other words, you can use it to read and write
40 your DSA/RSA/etc. keys, but it does not generate new keys or
41 encrypt/sign data.
42
43 %description -l pl.UTF-8
44 Crypt::Keys to system do zarządzania kluczami publicznymi i prywatnymi
45 przechowywanymi na dysku. Celem tego modułu jest umożliwienie odczytu
46 i zapisu kluczy kryptograficznych o dowolnym kodowaniu (PEM, SSH
47 itd.). Może być używany jako interfejs do zarządzania kluczami, ale
48 nie zawiera implementacji żadnego algorytmu kryptograficznego
49 reprezentowanego przez klucze, którymi zarządza. Innymi słowy, potrafi
50 odczytywać i zapisywać klucze DSA/RSA/itp., ale nie jest w stanie
51 wygenerować nowych kluczy ani odszyfrować czy zaszyfrować danych.
52
53 %prep
54 %setup -q -n %{pdir}-%{pnam}-%{version}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor \
59         < /dev/null
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README ToDo
76 %{perl_vendorlib}/Crypt/Keys.pm
77 %{perl_vendorlib}/Crypt/Keys
78 %{_mandir}/man3/*
This page took 0.101044 seconds and 2 git commands to generate.