]> git.pld-linux.org Git - packages/perl-Crypt-GCrypt.git/blob - perl-Crypt-GCrypt.spec
- (libgcrypt)
[packages/perl-Crypt-GCrypt.git] / perl-Crypt-GCrypt.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    GCrypt
8 Summary:        Crypt::GCrypt - Perl interface to the GNU Cryptographic library
9 Name:           perl-Crypt-GCrypt
10 Version:        1.26
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d23084ed878e5d12d4956c39e6f2b813
17 URL:            http://search.cpan.org/dist/Crypt-GCrypt/
18 BuildRequires:  libgcrypt-devel
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Crypt::GCrypt provides an object interface to the C libgcrypt library.
25 It currently supports symmetric encryption/decryption and message
26 digests, while asymmetric cryptography is being worked on.
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make} \
35         CC="%{__cc}" \
36         OPTIMIZE="%{rpmcflags}"
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changelog README
52 %{perl_vendorarch}/Crypt/GCrypt.pm
53 %{perl_vendorarch}/Crypt/GCrypt
54 %dir %{perl_vendorarch}/auto/Crypt/GCrypt
55 %{perl_vendorarch}/auto/Crypt/GCrypt/GCrypt.bs
56 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/GCrypt/GCrypt.so
57 %{_mandir}/man3/Crypt::GCrypt*.3*
This page took 0.079846 seconds and 3 git commands to generate.