]> git.pld-linux.org Git - packages/perl-Crypt-Camellia.git/blob - perl-Crypt-Camellia.spec
a7a7d8b64de19ed6ec71b2af100193c14ec4b344
[packages/perl-Crypt-Camellia.git] / perl-Crypt-Camellia.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Camellia
8 Summary:        Crypt::Camellia - Crypt::CBC-compliant block cipher
9 Summary(pl.UTF-8):      Crypt::Camellia - szyfr blokowy kompatybilny z Crypt::CBC
10 Name:           perl-Crypt-Camellia
11 Version:        1.0.2
12 Release:        8
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ba2e8ffa62b22f0cc59c8c867318461a
17 URL:            http://search.cpan.org/dist/Crypt-Camellia/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Camellia is a variable-length key, 128-bit block cipher. It is the
24 NESSIE winner for 128-bit block ciphers. The default key length in
25 this implementation is 128 bits. This module supports the Crypt::CBC
26 interface.
27
28 %description -l pl.UTF-8
29 Camellia to 128-bitowy szyfr blokowy o zmiennej długości klucza. Jest
30 zwycięzcą NESSIE dla 128-bitowych szyfrów blokowych. Domyślny rozmiar
31 klucza w tej implementacji to 128 bitów. Moduł obsługuje interfejs
32 Crypt::CBC.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 cd examples
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54 for f in * ; do
55         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
56                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
57 done
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorarch}/Crypt/Camellia.pm
66 %dir %{perl_vendorarch}/auto/Crypt/Camellia
67 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Camellia/Camellia.so
68 %{_mandir}/man3/*
69 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.066992 seconds and 2 git commands to generate.