]> git.pld-linux.org Git - packages/perl-Crypt-Anubis.git/blob - perl-Crypt-Anubis.spec
ee96a4c4684c07a662c68519c8c13f1dae56f312
[packages/perl-Crypt-Anubis.git] / perl-Crypt-Anubis.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Anubis
7 Summary:        Crypt::Anubis - Crypt::CBC-compliant block cipher
8 Summary(pl.UTF-8):      Crypt::Abubis - szyfr blokowy kompatybilny z Crypt::CBC
9 Name:           perl-Crypt-Anubis
10 Version:        1.0.4
11 Release:        14
12 License:        GPL v2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  aa62fb3a199063b5dff8bcbfc632338e
16 URL:            http://search.cpan.org/dist/Crypt-Anubis/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Anubis is a variable-length key, 128-bit block cipher designed by
23 Vincent Rijmen and Paulo S. L. M. Barreto. Key length can be 128, 160,
24 192, 224, 256, 288, or 320 bits. The default key length used in this
25 implementation is 128 bits (16 bytes). This module supports the
26 Crypt::CBC interface.
27
28 %description -l pl.UTF-8
29 Anubis to 128-bitowy szyfr blokowy o zmiennej długości klucza
30 opracowany przez Vincenta Rijmena i Paulo S. L. M. Baretto. Klucz może
31 mieć długość 128, 160, 192, 224, 256, 228 lub 320 bitów. Domyślna
32 długość klucza w tej implementacji to 128 bitów (16 bajtów). Ten moduł
33 obsługuje interfejs Crypt::CBC.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 cd examples
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 for f in * ; do
56         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
57                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
58 done
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorarch}/Crypt/Anubis.pm
67 %dir %{perl_vendorarch}/auto/Crypt/Anubis
68 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Anubis/Anubis.so
69 %{_mandir}/man3/*
70 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.064378 seconds and 2 git commands to generate.