]> git.pld-linux.org Git - packages/perl-Coro.git/blob - perl-Coro.spec
aacc629af7e8de389b2dc34b113de6eacd4e145b
[packages/perl-Coro.git] / perl-Coro.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Coro
6 %define         pnam    Coro
7 %define         pver    6.511
8 Summary:        Coro - do events the coro-way
9 Summary(pl.UTF-8):      Coro - obsługa zdarzeń na sposób coro
10 Name:           perl-Coro
11 Version:        6.51.1
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pnam}-%{pver}.tar.gz
17 # Source0-md5:  bcad7051f573fed680eaf72e64e2140e
18 Patch0:         kill-blocked-test.patch
19 Patch1:         coro-5.24.patch
20 URL:            http://search.cpan.org/dist/Coro/
21 BuildRequires:  perl-AnyEvent >= 2:5.0
22 BuildRequires:  perl-EV >= 1:4.0
23 BuildRequires:  perl-Event >= 1.08
24 BuildRequires:  perl-devel >= 1:5.8.2
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  sed >= 4.0
27 %if %{with tests}
28 BuildRequires:  perl-AnyEvent-Impl-EV
29 BuildRequires:  perl-AnyEvent-Impl-Event
30 BuildRequires:  perl-Guard >= 0.5
31 BuildRequires:  perl-Storable >= 2.15
32 BuildRequires:  perl-Time-HiRes
33 BuildRequires:  perl-common-sense
34 %endif
35 Requires:       perl-AnyEvent >= 2:5.0
36 Requires:       perl-BDB >= 1.5
37 Requires:       perl-EV >= 1:4.0
38 Requires:       perl-Guard >= 0.5
39 Requires:       perl-Storable >= 2.15
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 This module enables you to create programs using the powerful Event
44 model (and module), while retaining the linear style known from simple
45 or threaded programs.
46
47 %description -l pl.UTF-8
48 Ten moduł pozwala na tworzenie programów przy użyciu potężnego modelu
49 (i modułu) Event z zachowaniem liniowego stylu znanego z prostych lub
50 wątkowych programów.
51
52 %prep
53 %setup -q -n %{pnam}-%{pver}
54 %patch0 -p1
55 %patch1 -p1
56
57 %{__sed} -i "s^/opt/bin/perl^%{_bindir}/perl^" Coro/jit*pl
58
59 %build
60 echo "y" | %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make} \
63         CC="%{__cc}" \
64         OPTIMIZE="%{rpmcflags}"
65
66 %{?with_tests:%{__make} -j1 test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc COPYING Changes INSTALL README README.linux-glibc
80 %{perl_vendorarch}/Coro.pm
81 %{perl_vendorarch}/Coro
82 %dir %{perl_vendorarch}/auto/Coro
83 %dir %{perl_vendorarch}/auto/Coro/EV
84 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/EV/EV.so
85 %dir %{perl_vendorarch}/auto/Coro/Event
86 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/Event/Event.so
87 %dir %{perl_vendorarch}/auto/Coro/State
88 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/State/State.so
89 %{_mandir}/man3/Coro*.3pm*
This page took 0.040254 seconds and 2 git commands to generate.