]> git.pld-linux.org Git - packages/perl-Coro.git/blob - perl-Coro.spec
4ef2de94e728684e3bbade668de77d5185fca4ff
[packages/perl-Coro.git] / perl-Coro.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Coro
6 %define         pnam    Coro
7 Summary:        Coro - do events the coro-way
8 Summary(pl.UTF-8):      Coro - obsługa zdarzeń na sposób coro
9 Name:           perl-Coro
10 Version:        6.57
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fa5970a2a2f3df9d68d4369c7dde1a55
17 Patch0:         kill-blocked-test.patch
18 URL:            https://metacpan.org/dist/Coro
19 BuildRequires:  perl-AnyEvent >= 2:5.0
20 BuildRequires:  perl-Canary-Stability
21 BuildRequires:  perl-EV >= 1:4.0
22 BuildRequires:  perl-Event >= 1.08
23 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.52
24 BuildRequires:  perl-devel >= 1:5.8.9
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  rpmbuild(macros) >= 1.745
27 BuildRequires:  sed >= 4.0
28 %if %{with tests}
29 BuildRequires:  perl-AnyEvent-Impl-EV
30 BuildRequires:  perl-AnyEvent-Impl-Event
31 BuildRequires:  perl-Guard >= 0.5
32 BuildRequires:  perl-Storable >= 2.15
33 BuildRequires:  perl-Time-HiRes
34 BuildRequires:  perl-common-sense
35 %endif
36 Requires:       perl-AnyEvent >= 2:5.0
37 Requires:       perl-BDB >= 1.5
38 Requires:       perl-EV >= 1:4.0
39 Requires:       perl-Guard >= 0.5
40 Requires:       perl-Storable >= 2.15
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 This module enables you to create programs using the powerful Event
45 model (and module), while retaining the linear style known from simple
46 or threaded programs.
47
48 %description -l pl.UTF-8
49 Ten moduł pozwala na tworzenie programów przy użyciu potężnego modelu
50 (i modułu) Event z zachowaniem liniowego stylu znanego z prostych lub
51 wątkowych programów.
52
53 %prep
54 %setup -q -n %{pnam}-%{version}
55 %patch0 -p1
56
57 %{__sed} -i "s^/opt/bin/perl^%{_bindir}/perl^" Coro/jit*pl
58
59 %build
60 echo "y" | %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make} \
63         CC="%{__cc}" \
64         OPTIMIZE="%{rpmcflags}"
65
66 %{?with_tests:%{__make} -j1 test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc COPYING Changes INSTALL README README.linux-glibc
80 %{perl_vendorarch}/Coro.pm
81 %{perl_vendorarch}/Coro
82 %dir %{perl_vendorarch}/auto/Coro
83 %dir %{perl_vendorarch}/auto/Coro/EV
84 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/EV/EV.so
85 %dir %{perl_vendorarch}/auto/Coro/Event
86 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/Event/Event.so
87 %dir %{perl_vendorarch}/auto/Coro/State
88 %attr(755,root,root) %{perl_vendorarch}/auto/Coro/State/State.so
89 %{_mandir}/man3/Coro*.3pm*
This page took 0.151762 seconds and 2 git commands to generate.