]> git.pld-linux.org Git - packages/perl-Config-Grammar.git/blob - perl-Config-Grammar.spec
adapter, cleanups
[packages/perl-Config-Grammar.git] / perl-Config-Grammar.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Config
6 %define         pnam    Grammar
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Config::Grammar - A grammar-based, user-friendly config parser
9 Name:           perl-Config-Grammar
10 Version:        1.10
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Config/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  ce904f687f1ee9c70521142a2e0f15c9
16 URL:            http://search.cpan.org/dist/Config-Grammar/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Config::Grammar is a module to parse configuration files.
24
25 The configuration may consist of multiple-level sections with
26 assignments and tabular data. The parsed data will be returned as a
27 hash containing the whole configuration. Config::Grammar uses a
28 grammar that is supplied upon creation of a Config::Grammar object to
29 parse the configuration file and return helpful error messages in case
30 of syntax errors. Using the makepod method you can generate
31 documentation of the configuration file format.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__make} pure_install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %{perl_vendorlib}/Config/*.pm
55 %{perl_vendorlib}/Config/Grammar
56 %{_mandir}/man3/*
This page took 0.080218 seconds and 3 git commands to generate.