]> git.pld-linux.org Git - packages/perl-Compress-LZF.git/blob - perl-Compress-LZF.spec
96656e62fd0ef1b6ba0d54a386bb8c19a51ece95
[packages/perl-Compress-LZF.git] / perl-Compress-LZF.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Compress
7 %define         pnam    LZF
8 Summary:        Compress::LZF Perl module - extremely leight-weight Lev-Zimpel-Free compression
9 Summary(pl.UTF-8):      Moduł Perla Compress::LZF - ekstremalnie lekka kompresja Lev-Zimpel-Free
10 Name:           perl-Compress-LZF
11 Version:        3.43
12 Release:        8
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Compress/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b9dcb1bae6dc48ec45dd370e75000c05
18 URL:            http://search.cpan.org/dist/Compress-LZF/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 LZF is an extremely fast (not that much slower than a pure memcpy)
25 compression algorithm. It is ideal for applications where you want to
26 save *some* space but not at the cost of speed. It is ideal for
27 repetitive data as well. The module is self-contained and very small
28 (no large library to be pulled in). It is also free, so there should
29 be no problems incoporating this module into commercial programs. It
30 is believed that it is free from any patents.
31
32 %description -l pl.UTF-8
33 LZF jest ekstremalnie szybkim (nie tak dużo wolniejszym od memcpy)
34 algorytmem kompresji. Jest idealny dla programów, które chcą
35 zaoszczędzić *trochę* miejsca, ale nie kosztem szybkości. Jest idealny
36 dla powtarzających się danych. Moduł jest mały i nie wymaga żadnej
37 dodatkowej dużej biblioteki. Jest wolnodostępny, więc nie powinno być
38 problemów z wykorzystaniem go w komercyjnych programach. Według
39 aktualnego stanu wiedzy jest wolny od patentów.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make} \
48         CC="%{__cc}" \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorarch}/Compress/LZF.pm
66 %dir %{perl_vendorarch}/auto/Compress/LZF
67 %attr(755,root,root) %{perl_vendorarch}/auto/Compress/LZF/*.so
68 %{_mandir}/man3/Compress::LZF.3pm*
This page took 0.105714 seconds and 2 git commands to generate.