]> git.pld-linux.org Git - packages/perl-Clone-PP.git/blob - perl-Clone-PP.spec
ef207348be4ea5a15c2e8a1c5db75b246e51035e
[packages/perl-Clone-PP.git] / perl-Clone-PP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Clone
7 %define pnam    PP
8 Summary:        Clone::PP - Recursively copy Perl datatypes
9 #Summary(pl.UTF-8):     
10 Name:           perl-Clone-PP
11 Version:        1.07
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Clone/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d401b88f44e98fa0d984da7c7b6a4cd1
18 URL:            http://search.cpan.org/dist/Clone-PP/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a general-purpose clone function to make deep
28 copies of Perl data structures. It calls itself recursively to copy
29 nested hash, array, scalar and reference types, including tied
30 variables and objects.
31
32 # %description -l pl.UTF-8
33 # TODO
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README
57 %{perl_vendorlib}/Clone/*.pm
58 %{_mandir}/man3/*
This page took 0.023396 seconds and 2 git commands to generate.