]> git.pld-linux.org Git - packages/perl-Class-XPath.git/blob - perl-Class-XPath.spec
use generic url
[packages/perl-Class-XPath.git] / perl-Class-XPath.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    XPath
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Class::XPath - module that adds XPath matching to object trees
9 Summary(pl.UTF-8):      Class::XPath - moduł dodający dopasowywanie XPath do drzew obiektów
10 Name:           perl-Class-XPath
11 Version:        1.4
12 Release:        2
13 # same as perl 5
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  22ff3d2536027f3a9f59c6eb849fa610
18 URL:            http://search.cpan.org/dist/Class-XPath/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module adds XPath-style matching to your object trees. This means
26 that you can find nodes using an XPath-esque query with "match()" from
27 anywhere in the tree. Also, the "xpath()" method returns a unique path
28 to a given node which can be used as an identifier.
29
30 %description -l pl.UTF-8
31 Ten moduł dodaje dopasowywanie w stylu XPath do drzew obiektów.
32 Oznacza to, że można szukać węzłów przy użyciu zapytania typu XPath
33 funkcją "match()" z każdego miejsca w drzewie. Ponadto metoda
34 "xpath()" zwraca unikalną ścieżkę do danego węzła, którą można używać
35 jako identyfikator.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Class/XPath.pm
61 %{_mandir}/man3/*
This page took 0.068897 seconds and 3 git commands to generate.