]> git.pld-linux.org Git - packages/perl-Class-Singleton.git/blob - perl-Class-Singleton.spec
- updated to 1.5
[packages/perl-Class-Singleton.git] / perl-Class-Singleton.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Class
7 %define         pnam    Singleton
8 Summary:        Class::singleton - implementation of a "Singleton" class
9 Summary(pl.UTF-8):      Class::Singleton - implementacja klasy Singleton
10 Name:           perl-Class-Singleton
11 Version:        1.5
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  6a2524f590eda075f4bc929598119241
18 URL:            http://search.cpan.org/dist/Class-Singleton/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Obsoletes:      perl-Class-Sigleton
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This is the Class::Singleton module. A Singleton describes an object
27 class that can have only one instance in any system. An example of
28 a Singleton might be a print spooler or system registry. This module
29 implements a Singleton class from which other classes can be derived.
30 By itself, the Class::Singleton module does very little other than
31 manage the instantiation of a single object. In deriving a class from
32 Class::Singleton, your module will inherit the Singleton instantiation
33 method and can implement whatever specific functionality is required.
34
35 %description -l pl.UTF-8
36 To jest moduł Class::Singleton. Singleton opisuje obiekt klasy, który
37 ma tylko jedną instancję w systemie - na przykład serwer wydruków. Ten
38 moduł implementuje klasę Singleton, z której można dziedziczyć inne
39 klasy. Sam moduł Class::Singleton robi niewiele więcej niż samo
40 zarządzanie pojedynczą instancją obiektu. Poprzez dziedziczenie z
41 klasy z Class:Singleton, moduły odziedziczą istnienie pojedynczej
42 instancji w systemie, a dodatkowo mogą mieć zaimplementowaną właściwą
43 funkcjonalność.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes
67 %{perl_vendorlib}/Class/Singleton.pm
68 %{_mandir}/man3/Class::Singleton.3pm*
This page took 0.048734 seconds and 3 git commands to generate.