]> git.pld-linux.org Git - packages/perl-Class-Singleton.git/blob - perl-Class-Singleton.spec
a998e725db0dfe01920ed1952e2ffa77f61a0866
[packages/perl-Class-Singleton.git] / perl-Class-Singleton.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Class
7 %define         pnam    Singleton
8 Summary:        Class::singleton - implementation of a "Singleton" class
9 Summary(pl.UTF-8):      Class::Singleton - implementacja klasy Singleton
10 Name:           perl-Class-Singleton
11 Version:        1.4
12 Release:        1
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a18b108ab97e2107cbbe816d2b3e2ee3
17 URL:            http://search.cpan.org/dist/Class-Singleton/
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 Obsoletes:      perl-Class-Sigleton
23
24 %description
25 This is the Class::Singleton module. A Singleton describes an object
26 class that can have only one instance in any system. An example of
27 a Singleton might be a print spooler or system registry. This module
28 implements a Singleton class from which other classes can be derived.
29 By itself, the Class::Singleton module does very little other than
30 manage the instantiation of a single object. In deriving a class from
31 Class::Singleton, your module will inherit the Singleton instantiation
32 method and can implement whatever specific functionality is required.
33
34 %description -l pl.UTF-8
35 To jest moduł Class::Singleton. Singleton opisuje obiekt klasy, który
36 ma tylko jedną instancję w systemie - na przykład serwer wydruków. Ten
37 moduł implementuje klasę Singleton, z której można dziedziczyć inne
38 klasy. Sam moduł Class::Singleton robi niewiele więcej niż samo
39 zarządzanie pojedynczą instancją obiektu. Poprzez dziedziczenie z
40 klasy z Class:Singleton, moduły odziedziczą istnienie pojedynczej
41 instancji w systemie, a dodatkowo mogą mieć zaimplementowaną właściwą
42 funkcjonalność.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/Class/*
67 %{_mandir}/man3/*
This page took 0.115777 seconds and 2 git commands to generate.