]> git.pld-linux.org Git - packages/perl-Class-MOP.git/blob - perl-Class-MOP.spec
- release 8
[packages/perl-Class-MOP.git] / perl-Class-MOP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    MOP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Class::MOP - A Meta Object Protocol for Perl 5
9 Summary(pl.UTF-8):      Class::MOP - protokół metaobiektów (Meta Object Protocol) dla Perla 5
10 Name:           perl-Class-MOP
11 Version:        1.12
12 Release:        8
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Class/FLORA/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  685edbc1f388362f48ec67701b67acf6
18 URL:            http://search.cpan.org/dist/Class-MOP/
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Algorithm-C3
23 BuildRequires:  perl-Data-OptList
24 BuildRequires:  perl-Devel-GlobalDestruction
25 BuildRequires:  perl-List-MoreUtils >= 0.12
26 BuildRequires:  perl-MRO-Compat >= 0.05
27 BuildRequires:  perl-Module-Info
28 BuildRequires:  perl-Package-DeprecationManager >= 0.10
29 BuildRequires:  perl-Package-Stash >= 0.13
30 BuildRequires:  perl-Sub-Name >= 0.04
31 BuildRequires:  perl-Task-Weaken
32 BuildRequires:  perl-Test-Exception >= 0.21
33 BuildRequires:  perl-Test-Fatal >= 0.001
34 BuildRequires:  perl-Test-LeakTrace
35 BuildRequires:  perl-Test-NoTabs
36 BuildRequires:  perl-Test-Output
37 BuildRequires:  perl-Test-Requires >= 0.05
38 BuildRequires:  perl-Test-Simple >= 0.88
39 BuildRequires:  perl-Test-Spelling
40 BuildRequires:  perl-Try-Tiny
41 %endif
42 Requires:       perl-Sub-Identify >= 0.03
43 Requires:       perl-Sub-Name >= 0.02
44 Conflicts:      perl-Moose < 0:0.72
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Class::MOP is a fully functioning meta object protocol for the Perl 5
49 object system. It makes no attempt to change the behavior or
50 characteristics of the Perl 5 object system, only to create a protocol
51 for its manipulation and introspection.
52
53 That said, it does attempt to create the tools for building a rich set
54 of extensions to the Perl 5 object system. Every attempt has been made
55 for these tools to keep to the spirit of the Perl 5 object system that
56 we all know and love.
57
58 %description -l pl.UTF-8
59 Class::MOP to w pełni funkcjonalny protokół metaobiektów dla systemu
60 obiektowego Perla 5. Nie próbuje zmieniać zachowania czy
61 charakterystyki systemu obiektowego Perla 5, a jedynie tworzy protokół
62 do własnych operacji i obserwacji.
63
64 Oznacza to, że klasa ta nie tworzy narzędzi do budowania bogatego
65 zbioru rozszerzeń do systemu obiektowego Perla 5 - dołożono wszelkich
66 starań, aby utrzymać te narzędzia w duchu znanego i lubianego systemu
67 obiektowego Perla 5.
68
69 %prep
70 %setup -q -n %{pdir}-%{pnam}-%{version}
71
72 %build
73 %{__perl} Makefile.PL \
74         INSTALLDIRS=vendor
75 %{__make} \
76         CC="%{__cc}" \
77         OPTIMIZE="%{rpmcflags}"
78
79 %{?with_tests:%{__make} test}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} pure_install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
88 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc Changes
96 %{perl_vendorarch}/metaclass.pm
97 %{perl_vendorarch}/Class/MOP.pm
98 %{perl_vendorarch}/Class/MOP
99 %dir %{perl_vendorarch}/auto/Class/MOP
100 %attr(755,root,root) %{perl_vendorarch}/auto/Class/MOP/MOP.so
101 %{_mandir}/man3/Class::MOP*.3pm*
102 %{_mandir}/man3/metaclass.3pm*
103 %{_examplesdir}/%{name}-%{version}
This page took 0.063645 seconds and 3 git commands to generate.