]> git.pld-linux.org Git - packages/perl-Class-Load.git/blob - perl-Class-Load.spec
fdf0a2b1c1ba9159401523e803bc965e1720cbf8
[packages/perl-Class-Load.git] / perl-Class-Load.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Class
6 %define         pnam    Load
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Class::Load - a working (require "Class::Name") and more
9 Summary(pl.UTF-8):      Class::Load - działające (require "Klasa::Nazwa") i inne
10 Name:           perl-Class-Load
11 Version:        0.25
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e4c831c08df592ce8dfee0c7cfc12fd7
18 URL:            http://search.cpan.org/dist/Class-Load/
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Data-OptList
24 BuildRequires:  perl-Module-Implementation >= 0.04
25 BuildRequires:  perl-Module-Runtime >= 0.012
26 BuildRequires:  perl-Package-Stash >= 0.14
27 BuildRequires:  perl-Scalar-List-Utils
28 BuildRequires:  perl-Test-Fatal
29 BuildRequires:  perl-Test-Requires
30 BuildRequires:  perl-Test-Simple >= 0.88
31 BuildRequires:  perl-Try-Tiny
32 BuildRequires:  perl-version
33 %endif
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 require EXPR only accepts Class/Name.pm style module names, not
39 Class::Name. How frustrating! For that, we provide load_class
40 'Class::Name'.
41
42 It's often useful to test whether a module can be loaded, instead of
43 throwing an error when it's not available. For that, we provide
44 try_load_class 'Class::Name'.
45
46 Finally, sometimes we need to know whether a particular class has been
47 loaded. Asking %%INC is an option, but that will miss inner packages
48 and any class for which the filename does not correspond to the
49 package name. For that, we provide is_class_loaded 'Class::Name'.
50
51 %description -l pl.UTF-8
52 require EXPR przyjmuje tylko nazwy modułów w stylu Klasa/Nazwa.pm, a
53 nie Klasa::Nazwa - jest to frustrujące. Dlatego moduł ten udostępnia
54 funkcję load_class 'Klasa::Nazwa'.
55
56 Często przydaje się sprawdzić, czy moduł może być załadowany, zamiast
57 rzucania błędu, kiedy jest niedostępny. Dlatego modułu ten udostępnia
58 funkcję try_load_class 'Klasa::Nazwa'.
59
60 W końcu - czasem trzeba sprawdzić, czy dana klasa została załadowana.
61 Sprawdzanie %%INC jest jakąś opcją, ale pominie pakiety i klasy, dla
62 których nazwa pliku nie zgadza się z nazwą pakietu. Dlatego moduł ten
63 udostępnia funkcję is_class_loaded 'Klasa::Nazwa'.
64
65 %prep
66 %setup -q -n %{pdir}-%{pnam}-%{version}
67
68 %build
69 %{__perl} Makefile.PL \
70         INSTALLDIRS=vendor
71 %{__make}
72
73 %{?with_tests:%{__make} test}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} pure_install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc Changes README
87 %{perl_vendorlib}/Class/Load.pm
88 %{perl_vendorlib}/Class/Load
89 %{_mandir}/man3/Class::Load.3pm*
This page took 0.071875 seconds and 2 git commands to generate.