]> git.pld-linux.org Git - packages/perl-Class-ISA.git/blob - perl-Class-ISA.spec
use generic url
[packages/perl-Class-ISA.git] / perl-Class-ISA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    ISA
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Class::ISA Perl module - report the search path for a class's ISA tree
9 Summary(pl.UTF-8):      Moduł Perla Class::ISA - zwrócenie ścieżki przeszukiwania dla drzewa klasy ISA
10 Name:           perl-Class-ISA
11 Version:        0.36
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3a2ad203c8dc87d6c9de16215d00af47
18 URL:            http://search.cpan.org/dist/Class-ISA/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This library, Class::ISA, provides functions that return a list (in
26 order) of names of classes Perl would search to find a method, with no
27 duplicates.
28
29 %description -l pl.UTF-8
30 Biblioteka Class::ISA udostępnia funkcje zwracające (uporządkowaną)
31 listę nazw klas, które Perl powinien przeszukać w celu znalezienia
32 zadanej metody (bez duplikatów).
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc ChangeLog
56 %{perl_vendorlib}/Class/ISA.pm
57 %{_mandir}/man3/*
This page took 0.050128 seconds and 3 git commands to generate.