]> git.pld-linux.org Git - packages/perl-Class-Hash.git/blob - perl-Class-Hash.spec
use generic url
[packages/perl-Class-Hash.git] / perl-Class-Hash.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    Hash
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Class::Hash - Perl extension for hashes that look like classes
9 Summary(pl.UTF-8):      CLass::Hash - rozszerzenie Perla o hasze wyglądające jak klasy
10 Name:           perl-Class-Hash
11 Version:        1.01
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5366af138b4353755decf464afedccc4
18 URL:            http://search.cpan.org/dist/Class-Hash/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This component provides a method-based interface to a hash.
26 Occasionally, it's more convenient to have named methods to access a
27 hash than hash keys. This module generalizes this behavior. It tries
28 to work the tied hash interface inside-out.
29
30 This module tries to do as much or as little for you as you want and
31 provides a number of configuration options. The options allow you to
32 determine what kind of interface the object has. The interface may
33 also be altered after-the-fact.
34
35 %description -l pl.UTF-8
36 Ten pakiet dostarcza oparty na metodach interfejs do haszy. Czasem
37 bardziej wygodne jest mieć nazwane metody do dostępu do hasza zamiast
38 kluczy. Ten moduł generalizuje takie zachowanie. Próbuje wyprowadzić
39 interfejs powiązanego hasza.
40
41 Ten moduł próbuje zrobić jak najwięcej lub jak najmniej za programistę
42 w zależności od potrzeb, dostarczając wiele opcji konfiguracyjnych.
43 Opcje te pozwalają określić rodzaj interfejsu, jaki ma obiekt. Ten
44 interfejs może być także modyfikowany później.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52
53 %{__make}
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorlib}/Class/Hash.pm
69 %{_mandir}/man3/*
This page took 0.066157 seconds and 3 git commands to generate.