]> git.pld-linux.org Git - packages/perl-Class-DBI-Plugin.git/blob - perl-Class-DBI-Plugin.spec
use generic url
[packages/perl-Class-DBI-Plugin.git] / perl-Class-DBI-Plugin.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Class
6 %define pnam    DBI-Plugin
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Class::DBI::Plugin - Abstract base class for Class::DBI plugins
9 Name:           perl-Class-DBI-Plugin
10 Version:        0.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b020611a93fe51cbcdfd78f2cbf872cb
17 URL:            http://search.cpan.org/dist/Class-DBI-Plugin/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Class::DBI) >= 0.9
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Class::DBI::Plugin is an abstract base class for Class::DBI plugins.
28 Its purpose is to make writing plugins easier. Writers of plugins
29 should be able to concentrate on the functionality their module
30 provides, instead of having to deal with the symbol table hackery
31 involved when writing a plugin module.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__make} pure_install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes
54 %{perl_vendorlib}/Class/DBI/*.pm
55 %{_mandir}/man3/*
This page took 0.118529 seconds and 3 git commands to generate.