]> git.pld-linux.org Git - packages/perl-Class-DBI-Plugin-RetrieveAll.git/blob - perl-Class-DBI-Plugin-RetrieveAll.spec
use generic url
[packages/perl-Class-DBI-Plugin-RetrieveAll.git] / perl-Class-DBI-Plugin-RetrieveAll.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    DBI-Plugin-RetrieveAll
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Determine type information for columns
9 Summary(pl.UTF-8):      Określanie informacji o typie dla kolumn
10 Name:           perl-Class-DBI-Plugin-RetrieveAll
11 Version:        1.04
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  859fe774e6d74636b6406b821d4d66d1
18 URL:            http://search.cpan.org/dist/Class-DBI-Plugin-RetrieveAll/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-DBI
23 BuildRequires:  perl-DBD-SQLite
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module allows Class::DBI-based classes to query their columns for
30 data type information in a database-independent manner.
31
32 %description -l pl.UTF-8
33 Ten moduł pozwala klasom opartym na Class::DBI na odpytywanie kolumn o
34 informacje o typie w sposób niezależny od bazy danych.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make}
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes
58 %{perl_vendorlib}/Class/DBI/Plugin/*
59 %{_mandir}/man3/*
This page took 0.128978 seconds and 3 git commands to generate.