]> git.pld-linux.org Git - packages/perl-Class-DBI-Plugin-CountSearch.git/blob - perl-Class-DBI-Plugin-CountSearch.spec
use generic url
[packages/perl-Class-DBI-Plugin-CountSearch.git] / perl-Class-DBI-Plugin-CountSearch.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Class
6 %define pnam    DBI-Plugin-CountSearch
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Class::DBI::Plugin::CountSearch - get COUNT(*) results from the database with search functionality
9 Summary(pl.UTF-8):      Class::DBI::Plugin::CountSearch - pobieranie wyników COUNT(*) z bazy danych z możliwością wyszukiwania
10 Name:           perl-Class-DBI-Plugin-CountSearch
11 Version:        1.02
12 Release:        0.1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tgz
17 # Source0-md5:  f030e7d98161a4f9c05bf53a36d9eb3b
18 URL:            http://search.cpan.org/dist/Class-DBI-Plugin-CountSearch/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This plugin adds support for COUNT(*) results directly from the
26 database without having to load the records into an iterator or array.
27 It provides 'count_search' and 'count_search_like' which take
28 arguments exactly like Class::DBI::search().
29
30 %description -l pl.UTF-8
31 Ta wtyczka dodaje obsługę wyników COUNT(*) bezpośrednio z bazy danych
32 bez potrzeby wczytywania rekordów do iteratora lub tablicy. Udostępnia
33 'count_search' i 'count_search_like' przyjmujące dokładnie takie
34 argumenty, jak Class::DBI::search().
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes
58 %{perl_vendorlib}/Class/DBI/Plugin/CountSearch.pm
59 %{_mandir}/man3/*
This page took 0.462573 seconds and 3 git commands to generate.