]> git.pld-linux.org Git - packages/perl-Class-Container.git/blob - perl-Class-Container.spec
use generic url
[packages/perl-Class-Container.git] / perl-Class-Container.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    Container
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Class::Container - glues object frameworks together transparently
9 Summary(pl.UTF-8):      Class::Container - przezroczyste sklejanie szkieletów obiektów
10 Name:           perl-Class-Container
11 Version:        0.12
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  6896bdb4464b96ad638e22b0400acbc9
18 URL:            http://search.cpan.org/dist/Class-Container/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Params-Validate >= 0.18
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautoreq      'perl(Scalar::Util)'
28
29 %description
30 This class facilitates building frameworks of several classes that
31 inter-operate. It was first designed and built for "HTML::Mason", in
32 which the Compiler, Lexer, Interpreter, Resolver, Component, Buffer,
33 and several other objects must create each other transparently,
34 passing the appropriate parameters to the right class, possibly
35 substituting their own subclass for any of these objects.
36
37 %description -l pl.UTF-8
38 Ta klasa ułatwia tworzenie szkieletu dla różnych, współpracujących ze
39 sobą, klas. Pierwotnie była zaprojektowana i stworzona dla
40 HTML::Mason, w którym Compiler, Lexer, Interpreter, Resolver,
41 Component, Buffer i kilka innych obiektów muszą tworzyć inne w sposób
42 przezroczysty, przekazując odpowiednie parametry do właściwej klasy,
43 być może także podstawiając swoją własną podklasę za dowolny z tych
44 obiektów.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48 # We do not sleep.
49 %{__perl} -ni -e 'print unless /sleep/' Makefile.PL
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/Class/Container.pm
71 %{_mandir}/man3/*.3pm*
This page took 0.062867 seconds and 3 git commands to generate.