]> git.pld-linux.org Git - packages/perl-Class-Accessor-Chained.git/blob - perl-Class-Accessor-Chained.spec
448e7ae6e15fff62f610e161d7fc753ad5220518
[packages/perl-Class-Accessor-Chained.git] / perl-Class-Accessor-Chained.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Class
7 %define pnam    Accessor-Chained
8 Summary:        Class::Accessor::Chained - make chained accessors
9 Summary(pl.UTF-8):      Class::Accessor::Chained - tworzenie łańcuchowych metod accessor
10 Name:           perl-Class-Accessor-Chained
11 Version:        0.01
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9825a1f30a70e55e61bb5660b2bd7365
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Accessor
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A chained accessor is one that always returns the object when called
28 with parameters (to set), and the value of the field when called with
29 no arguments.
30
31 This module subclasses Class::Accessor in order to provide the same
32 mk_accessors interface.
33
34 %description -l pl.UTF-8
35 Łańcuchowa metoda accessor to taka, która zawsze zwraca obiekt przy
36 wywołaniu z parametrami (do ustawienia), a wartość pola przy wywołaniu
37 bez parametrów.
38
39 Ten moduł jest podklasą Class::Accessor dla zapewnienia tego samego
40 interfejsu mk_accessors.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/Class/Accessor/*.pm
65 %{perl_vendorlib}/Class/Accessor/Chained
66 %{_mandir}/man3/*
This page took 0.045562 seconds and 2 git commands to generate.