]> git.pld-linux.org Git - packages/perl-Chemistry-MolecularMass.git/blob - perl-Chemistry-MolecularMass.spec
- rel 2
[packages/perl-Chemistry-MolecularMass.git] / perl-Chemistry-MolecularMass.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Chemistry
7 %define         pnam    MolecularMass
8 Summary:        Chemistry::MolecularMass - calculating molecular mass of a chemical compound given its chemical formula
9 Summary(pl.UTF-8):      Chemistry::MolecularMass - obliczanie masy cząsteczkowej związków zadanych wzorem chemicznym
10 Name:           perl-Chemistry-MolecularMass
11 Version:        0.1
12 Release:        2
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d0d56e49920ca0f18237ef81ef946ca6
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Chemistry::MolecularMass is an Object Oriented Perl module for
23 calculating molecular mass of chemical compounds implemented with Perl
24 and C. Molecular masses of elements stored in the module follow
25 recommendations of IUPAC (1995). The module includes elements from
26 H(1) through Uuu(113) and isotopes of hydrogen: deuterium and tritium.
27
28 %description -l pl.UTF-8
29 Chemistry::MolecularMass to obiektowo zorientowany moduł Perla do
30 obliczania masy cząsteczkowej związków chemicznych zaimplementowany w
31 Perlu i C. Masy cząsteczkowe pierwiastków są zapisane w module zgodnie
32 z zaleceniami IUPAC (1995). Moduł zawiera pierwiastki od H(1) do
33 Uuu(113) oraz izotopy wodoru: deuter i tryt.
34
35 %prep
36 %setup -q -n %{pdir}/%{pnam}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Chemistry/MolecularMass.pm
61 %dir %{perl_vendorarch}/auto/Chemistry/MolecularMass
62 %{perl_vendorarch}/auto/Chemistry/MolecularMass/MolecularMass.bs
63 %attr(755,root,root) %{perl_vendorarch}/auto/Chemistry/MolecularMass/MolecularMass.so
64 %{_mandir}/man3/*
This page took 0.046678 seconds and 4 git commands to generate.