]> git.pld-linux.org Git - packages/perl-Chemistry-MolecularMass.git/blob - perl-Chemistry-MolecularMass.spec
- typo
[packages/perl-Chemistry-MolecularMass.git] / perl-Chemistry-MolecularMass.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Chemistry
7 %define pnam    MolecularMass
8 Summary:        Chemistry::MolecularMass - calculating molecular mass of a chemical compound given its chemical formula
9 Summary(pl):    Chemistry::MolecularMass - obliczanie masy cz±steczkowej zwi±zków zadanych wzorem chemicznym
10 Name:           perl-Chemistry-MolecularMass
11 Version:        0.1
12 Release:        1
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d0d56e49920ca0f18237ef81ef946ca6
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Chemistry::MolecularMass is an Object Oriented Perl module for
23 calculating molecular mass of chemical compounds implemented with Perl
24 and C. Molecular masses of elements stored in the module follow
25 recommendations of IUPAC (1995). The module includes elements from
26 H(1) through Uuu(113) and isotopes of hydrogen: deuterium and tritium.
27
28 %description -l pl
29 Chemistry::MolecularMass to obiektowo zorientowany modu³ Perla do
30 obliczania masy cz±steczkowej zwi±zków chemicznych zaimplementowany w
31 Perlu i C. Masy cz±steczkowe pierwiastków s± zapisane w module zgodnie
32 z zaleceniami IUPAC (1995). Modu³ zawiera pierwiastki od H(1) do
33 Uuu(113) oraz izotopy wodoru: deuter i tryt.
34
35 %prep
36 %setup -q -n %{pdir}/%{pnam}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make} \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/Chemistry/MolecularMass.pm
60 %dir %{perl_vendorarch}/auto/Chemistry/MolecularMass
61 %{perl_vendorarch}/auto/Chemistry/MolecularMass/MolecularMass.bs
62 %attr(755,root,root) %{perl_vendorarch}/auto/Chemistry/MolecularMass/MolecularMass.so
63 %{_mandir}/man3/*
This page took 0.03069 seconds and 4 git commands to generate.