]> git.pld-linux.org Git - packages/perl-Chemistry-MolecularMass.git/blob - perl-Chemistry-MolecularMass.spec
- rebuild with perl 5.28.0
[packages/perl-Chemistry-MolecularMass.git] / perl-Chemistry-MolecularMass.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Chemistry
6 %define         pnam    MolecularMass
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Chemistry::MolecularMass - calculating molecular mass of a chemical compound given its chemical formula
9 Summary(pl.UTF-8):      Chemistry::MolecularMass - obliczanie masy cząsteczkowej związków zadanych wzorem chemicznym
10 Name:           perl-Chemistry-MolecularMass
11 Version:        0.1
12 Release:        12
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d0d56e49920ca0f18237ef81ef946ca6
17 URL:            http://search.cpan.org/dist/Chemistry-MolecularMass/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Chemistry::MolecularMass is an Object Oriented Perl module for
24 calculating molecular mass of chemical compounds implemented with Perl
25 and C. Molecular masses of elements stored in the module follow
26 recommendations of IUPAC (1995). The module includes elements from
27 H(1) through Uuu(113) and isotopes of hydrogen: deuterium and tritium.
28
29 %description -l pl.UTF-8
30 Chemistry::MolecularMass to obiektowo zorientowany moduł Perla do
31 obliczania masy cząsteczkowej związków chemicznych zaimplementowany w
32 Perlu i C. Masy cząsteczkowe pierwiastków są zapisane w module zgodnie
33 z zaleceniami IUPAC (1995). Moduł zawiera pierwiastki od H(1) do
34 Uuu(113) oraz izotopy wodoru: deuter i tryt.
35
36 %prep
37 %setup -q -n %{pdir}/%{pnam}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/Chemistry/MolecularMass.pm
62 %dir %{perl_vendorarch}/auto/Chemistry/MolecularMass
63 %attr(755,root,root) %{perl_vendorarch}/auto/Chemistry/MolecularMass/MolecularMass.so
64 %{_mandir}/man3/*
This page took 0.059576 seconds and 3 git commands to generate.