]> git.pld-linux.org Git - packages/perl-Cache-DB_File.git/blob - perl-Cache-DB_File.spec
use generic url
[packages/perl-Cache-DB_File.git] / perl-Cache-DB_File.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Cache
6 %define         pnam    DB_File
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Cache::DB_File - memory cache which, when full, swaps to DB_File database
9 Summary(pl.UTF-8):      Cache::DB_File - bufor pamięci określonej wielkości, z wymianą do bazy DB_File
10 Name:           perl-Cache-DB_File
11 Version:        0.2
12 Release:        7
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://backpan.perl.org/authors/id/A/AS/ASKSH/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  48fa9e428e2d28ca90253031d0bf9d93
18 URL:            http://search.cpan.org/dist/Cache-DB_File/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-DB_File >= 1
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Cache::DB_File is a cache system that has a optional limit on the
29 number of elements, and optional time limits on elements. When the
30 memory cache reaches its limit, it will swap infrequently used
31 elements to disk.
32
33 %description -l pl.UTF-8
34 Cache::DB_File to system bufora, który ma opcjonalny limit na liczbę
35 elementów i opcjonalne limity czasowe na elementy. kiedy bufor w
36 pamięci osiągnie limit, rzadko używane elementy zostaną zrzucone na
37 dysk.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %{perl_vendorlib}/Cache/*.pm
61 %{_mandir}/man3/*
This page took 0.108507 seconds and 3 git commands to generate.