]> git.pld-linux.org Git - packages/perl-CSS-Tiny.git/blob - perl-CSS-Tiny.spec
7428cd74ea2d0bf675f98d43abe65e308863ff7c
[packages/perl-CSS-Tiny.git] / perl-CSS-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    CSS
6 %define         pnam    Tiny
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CSS::Tiny - Read/Write .css files with as little code as possible
9 Summary(pl.UTF-8):      CSS::Tiny - odczyt/zapis plików .css przy użyciu jak najmniejszego kodu
10 Name:           perl-CSS-Tiny
11 Version:        1.19
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/CSS/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f3f2f3d67d35d0e2b4c3b53c8b3f9483
18 URL:            http://search.cpan.org/dist/CSS-Tiny/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple >= 0.47
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 CSS::Tiny is a Perl class to read and write .css stylesheets with as 
29 little code as possible, reducing load time and memory overhead.
30 CSS.pm requires about 2.6 meg of RAM to load, which is a large amount
31 of overhead if you only want to do trivial things.
32
33 %description -l pl.UTF-8
34 CSS::Tiny to klasa Perla do odczytu i zapisu arkuszy styli .css przy
35 użyciu jak najmniejszej ilości kodu, co zmniejsza czas ładowania i
36 narzut pamięciowy. CSS.pm wymaga około 2.6MB RAM, co jest znacznym
37 narzutem, jeśli chce się zrobić coś prostego.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/CSS/Tiny.pm
62 %{_mandir}/man3/CSS::Tiny.3pm*
This page took 0.060812 seconds and 2 git commands to generate.