]> git.pld-linux.org Git - packages/perl-CPS.git/blob - perl-CPS.spec
0d727cab628033fcf905a528c3de3d50ec745665
[packages/perl-CPS.git] / perl-CPS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    CPS
7 %define         pnam    CPS
8 Summary:        CPS - manage flow of control in Continuation-Passing Style
9 Summary(pl.UTF-8):      CPS - zarządzanie przepływem sterowania w stylu przekazywania kontynuacji
10 Name:           perl-CPS
11 Version:        0.12
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/P/PE/PEVANS/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2c69c2fd383ee8f3cdc850681b39211d
18 URL:            http://search.cpan.org/dist/CPS/
19 BuildRequires:  perl-Test-Fatal
20 BuildRequires:  perl-Test-Identity
21 BuildRequires:  perl-Test-Refcount
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 CPS module allows to manage flow of control in Continuation-Passing
29 Style.
30
31 %description -l pl.UTF-8
32 Moduł CPS pozwala na zarządzanie przepływem sterowania w stylu
33 przekazywania kontynuacji (Continuation Passing).
34
35 %prep
36 %setup -q -n %{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/CPS.pm
57 %{perl_vendorlib}/CPS
58 %{_mandir}/man3/CPS*.3pm*
This page took 0.06317 seconds and 2 git commands to generate.