]> git.pld-linux.org Git - packages/perl-CPAN-Meta.git/blob - perl-CPAN-Meta.spec
- macros for perl autodeps
[packages/perl-CPAN-Meta.git] / perl-CPAN-Meta.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    CPAN
6 %define         pnam    Meta
7 Summary:        CPAN::Meta - the distribution metadata for a CPAN dist
8 Summary(pl.UTF-8):      CPAN::Meta - metadane dystrybucji dla CPAN
9 Name:           perl-CPAN-Meta
10 Version:        2.150010
11 # 2.150010 is bundled with perl 5.28
12 Release:        0.1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  40043190b75a1d598f9bee5ed70a44de
18 URL:            https://metacpan.org/release/CPAN-Meta
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
20 BuildRequires:  perl-devel >= 1:5.8.1
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl-CPAN-Meta-Requirements >= 2.121
25 BuildRequires:  perl-CPAN-Meta-YAML >= 0.011
26 BuildRequires:  perl-File-Temp >= 0.20
27 BuildRequires:  perl-JSON-PP >= 2.27300
28 BuildRequires:  perl-Scalar-List-Utils
29 BuildRequires:  perl-Test-Simple >= 0.96
30 BuildRequires:  perl-Version-Requirements >= 0.101020
31 BuildRequires:  perl-version >= 0.88
32 %endif
33 # as we unbundle Parse::CPAN::Meta here (for version see Changes)
34 Requires:       perl-Parse-CPAN-Meta >= 1.4422
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Software distributions released to the CPAN include a META.json or,
40 for older distributions, META.yml, which describes the distribution,
41 its contents, and the requirements for building and installing the
42 distribution. The data structure stored in the META.json file is
43 described in CPAN::Meta::Spec.
44
45 CPAN::Meta provides a simple class to represent this distribution
46 metadata (or distmeta), along with some helpful methods for
47 interrogating that data.
48
49 %description -l pl.UTF-8
50 Dystrybucje oprogramowania wydane do CPAN zawierają plik META.json lub
51 (w starszych wersjach) META.yml, opisujący dystrybucję, jej zawartość
52 i wymagania do budowania i instalowania dystrybucji. Struktura danych
53 zapisanych w pliku META.json jest opisana w CPAN::Meta::Spec.
54
55 CPAN::Meta udostępnia prostą klasę reprezentującą te metadane
56 dystrybucji (distmeta) wraz z kilkoma przydatnymi metodami do badania
57 tych danych.
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make}
66
67 %{?with_tests:%{__make} test}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} pure_install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Parse/CPAN/Meta.pm \
76         $RPM_BUILD_ROOT%{_mandir}/man3/Parse::CPAN::Meta.3pm
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Changes README Todo history
84 %{perl_vendorlib}/CPAN/Meta.pm
85 %{perl_vendorlib}/CPAN/Meta
86 %{_mandir}/man3/CPAN::Meta*.3pm*
This page took 0.10824 seconds and 3 git commands to generate.