]> git.pld-linux.org Git - packages/perl-CPAN-Meta-Requirements.git/blob - perl-CPAN-Meta-Requirements.spec
- macros for perl autodeps
[packages/perl-CPAN-Meta-Requirements.git] / perl-CPAN-Meta-Requirements.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    CPAN
6 %define         pnam    Meta-Requirements
7 Summary:        CPAN::Meta::Requirements - a set of version requirements for a CPAN dist
8 Summary(pl.UTF-8):      CPAN::Meta::Requirements - zbiór wymaganych wersji dla dystrybucji CPAN
9 Name:           perl-CPAN-Meta-Requirements
10 Version:        2.140
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8febe4f14f356e57fd1e2c342d56a64b
17 URL:            https://metacpan.org/release/CPAN-Meta-Requirements
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.17
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-File-Temp
24 BuildRequires:  perl-Scalar-List-Utils
25 BuildRequires:  perl-Test-Simple >= 0.88
26 BuildRequires:  perl-version >= 0.88
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A CPAN::Meta::Requirements object models a set of version constraints
33 like those specified in the META.yml or META.json files in CPAN
34 distributions. It can be built up by adding more and more constraints,
35 and it will reduce them to the simplest representation.
36
37 Logically impossible constraints will be identified immediately by
38 thrown exceptions.
39
40 %description -l pl.UTF-8
41 Obiekt CPAN::Meta::Requirements modeluje zbiór ograniczeń wersji,
42 takich jak te podawane w plikach META.yml lub META.json w
43 dystrybucjach CPAN. Mogą być tworzone poprzez dodawanie kolejnych
44 ograniczeń, a obiekt zredukuje je do najprostszej reprezentacji.
45
46 Ograniczenia logicznie niemożliwe zostaną zidentyfikowane natychmiast
47 poprzez rzucenie wyjątku.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/CPAN/Meta/Requirements.pm
72 %{_mandir}/man3/CPAN::Meta::Requirements.3pm*
This page took 0.24457 seconds and 3 git commands to generate.