]> git.pld-linux.org Git - packages/perl-CPAN-Meta-Requirements.git/blob - perl-CPAN-Meta-Requirements.spec
9aa122283a7886b53fbff6df72e2986ebfbe996c
[packages/perl-CPAN-Meta-Requirements.git] / perl-CPAN-Meta-Requirements.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    CPAN
6 %define         pnam    Meta-Requirements
7 Summary:        CPAN::Meta::Requirements - a set of version requirements for a CPAN dist
8 Summary(pl.UTF-8):      CPAN::Meta::Requirements - zbiór wymaganych wersji dla dystrybucji CPAN
9 Name:           perl-CPAN-Meta-Requirements
10 Version:        2.140
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8febe4f14f356e57fd1e2c342d56a64b
17 URL:            http://search.cpan.org/dist/CPAN-Meta-Requirements/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.17
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-File-Temp
23 BuildRequires:  perl-Scalar-List-Utils
24 BuildRequires:  perl-Test-Simple >= 0.88
25 BuildRequires:  perl-version >= 0.88
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 A CPAN::Meta::Requirements object models a set of version constraints
32 like those specified in the META.yml or META.json files in CPAN
33 distributions. It can be built up by adding more and more constraints,
34 and it will reduce them to the simplest representation.
35
36 Logically impossible constraints will be identified immediately by
37 thrown exceptions.
38
39 %description -l pl.UTF-8
40 Obiekt CPAN::Meta::Requirements modeluje zbiór ograniczeń wersji,
41 takich jak te podawane w plikach META.yml lub META.json w
42 dystrybucjach CPAN. Mogą być tworzone poprzez dodawanie kolejnych
43 ograniczeń, a obiekt zredukuje je do najprostszej reprezentacji.
44
45 Ograniczenia logicznie niemożliwe zostaną zidentyfikowane natychmiast
46 poprzez rzucenie wyjątku.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/CPAN/Meta/Requirements.pm
71 %{_mandir}/man3/CPAN::Meta::Requirements.3pm*
This page took 0.074553 seconds and 2 git commands to generate.