]> git.pld-linux.org Git - packages/perl-CGI-XMLForm.git/blob - perl-CGI-XMLForm.spec
use generic url
[packages/perl-CGI-XMLForm.git] / perl-CGI-XMLForm.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    XMLForm
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CGI::XMLForm Perl module
9 Summary(cs.UTF-8):      Modul CGI::XMLForm pro Perl
10 Summary(da.UTF-8):      Perlmodul CGI::XMLForm
11 Summary(de.UTF-8):      CGI::XMLForm Perl Modul
12 Summary(es.UTF-8):      Módulo de Perl CGI::XMLForm
13 Summary(fr.UTF-8):      Module Perl CGI::XMLForm
14 Summary(it.UTF-8):      Modulo di Perl CGI::XMLForm
15 Summary(ja.UTF-8):      CGI::XMLForm Perl モジュール
16 Summary(ko.UTF-8):      CGI::XMLForm 펄 모줄
17 Summary(nb.UTF-8):      Perlmodul CGI::XMLForm
18 Summary(pl.UTF-8):      Moduł Perla CGI::XMLForm
19 Summary(pt.UTF-8):      Módulo de Perl CGI::XMLForm
20 Summary(pt_BR.UTF-8):   Módulo Perl CGI::XMLForm
21 Summary(ru.UTF-8):      Модуль для Perl CGI::XMLForm
22 Summary(sv.UTF-8):      CGI::XMLForm Perlmodul
23 Summary(uk.UTF-8):      Модуль для Perl CGI::XMLForm
24 Summary(zh_CN.UTF-8):   CGI::XMLForm Perl 模块
25 Name:           perl-CGI-XMLForm
26 Version:        0.10
27 Release:        10
28 License:        GPL
29 Group:          Development/Languages/Perl
30 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
31 # Source0-md5:  89d5fcc3f0a3753aa184e9ae85474736
32 URL:            http://search.cpan.org/dist/CGI-XMLForm/
33 BuildRequires:  perl-XML-Parser >= 2.20
34 BuildRequires:  perl-devel >= 1:5.8.0
35 BuildRequires:  rpm-perlprov >= 4.1-13
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 CGI::XMLForm - Extension of CGI.pm which reads/generates formated XML.
41
42 %description -l pl.UTF-8
43 CGI::XMLForm - rozszerzenie CGI.pm umożliwiające czytanie/generowanie
44 dokumentów w formacie XML.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62 cp -p example* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README TODO
70 %{perl_vendorlib}/CGI/XMLForm.pm
71 %{perl_vendorlib}/CGI/XMLForm
72 %dir %{perl_vendorlib}/auto/CGI
73 %dir %{perl_vendorlib}/auto/CGI/XMLForm
74 %dir %{perl_vendorlib}/auto/CGI/XMLForm/Path
75 %{perl_vendorlib}/auto/CGI/XMLForm/Path/autosplit.ix
76 %{perl_vendorlib}/auto/CGI/XMLForm/Path/*.al
77 %{_mandir}/man3/*
78 %dir %{_examplesdir}/%{name}-%{version}
79 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
80 %{_examplesdir}/%{name}-%{version}/*.html
This page took 0.307532 seconds and 3 git commands to generate.