]> git.pld-linux.org Git - packages/perl-CGI-Widget.git/blob - perl-CGI-Widget.spec
use generic url
[packages/perl-CGI-Widget.git] / perl-CGI-Widget.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    Widget
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CGI::Widget - base class for CGI::Widget::
9 Summary(pl.UTF-8):      CGI::Widget - klasa bazowa dla CGI::Widget::
10 Name:           perl-CGI-Widget
11 Version:        0.15
12 Release:        5
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  70a57a75c17696fe57590efbaab787f8
17 URL:            http://search.cpan.org/dist/CGI-Widget/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-CGI
22 BuildRequires:  perl-Tree-DAG_Node
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The CGI::Widget module's purpose is to allow authors of CGI or other
29 dynamically generated HTML documents an easy way to create common, and
30 possibly complex, page elements.
31
32 %description -l pl.UTF-8
33 Zadaniem CGI::Widget jest udostępnienie autorom skryptów CGI (lub
34 korzystającym z innych technik dynamicznego tworzenia dokumentów HTML)
35 prostego sposobu na tworzenie wspólnych i możliwie złożonych elementów
36 stron.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %{perl_vendorlib}/%{pdir}/*.pm
60 %{perl_vendorlib}/%{pdir}/%{pnam}
61 %{_mandir}/man3/*
This page took 0.067564 seconds and 3 git commands to generate.