]> git.pld-linux.org Git - packages/perl-CGI-WeT.git/blob - perl-CGI-WeT.spec
use generic url
[packages/perl-CGI-WeT.git] / perl-CGI-WeT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    WeT
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CGI::WeT Perl module - suite of modules to themeify a website
9 Summary(pl.UTF-8):      Moduł Perla CGI::WeT - pakiet modułów do nadania motywów stronom WWW
10 Name:           perl-CGI-WeT
11 Version:        0.71
12 Release:        11
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  78528519a7a96511b96064d9a4d750ce
17 URL:            http://search.cpan.org/dist/CGI-WeT/
18 BuildRequires:  apache-mod_perl
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 3.0.3-16
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The collection of CGI::WeT::* modules allows a site to be built from
26 three major components:
27 (1) static themed HTML files,
28 (2) theme definitions,
29 (3) CGI scripts.
30
31 %description -l pl.UTF-8
32 Zestaw modułów CGI::WeT umożliwia zbudowanie stron WWW z trzech
33 podstawowych składników:
34 (1) statycznych plików HTML z motywami,
35 (2) definicji motywów,
36 (3) skryptów CGI.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54 cp -a scripts themes $RPM_BUILD_ROOT%{_examplesdir}/%{name}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/CGI/WeT.pm
63 %{perl_vendorlib}/CGI/WeT
64 %{_mandir}/man3/*
65 %{_examplesdir}/%{name}
This page took 0.076513 seconds and 3 git commands to generate.