]> git.pld-linux.org Git - packages/perl-CGI-Screen.git/blob - perl-CGI-Screen.spec
use generic url
[packages/perl-CGI-Screen.git] / perl-CGI-Screen.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    Screen
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CGI::Screen - Perl extension for easy creation of multi screen CGI scripts
9 Summary(pl.UTF-8):      CGI::Screen - rozszerzenia Perla do łatwego tworzenia wieloekranowych skryptów CGI
10 Name:           perl-CGI-Screen
11 Version:        0.122
12 Release:        11
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3bcbb56df1852bd20183cd9eda3ea6e9
17 URL:            http://search.cpan.org/dist/CGI-Screen/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 CGI::Screen is a subclass of "CGI" which allows the esay(TM) creation
25 of simple multi screen CGI scripts. By 'multi screen' I mean scripts
26 which present different screens to the user when called with different
27 parameters. This is the common case for scripts linking to themselves.
28
29 %description -l pl.UTF-8
30 CGI::Screen jest podklasą "CGI", która umożliwia łatwe(TM) tworzenie
31 wieloekranowych skryptów CGI. ,,Skrypt wieloekranowy'' oznacza tu
32 skrypt, który przedstawia użytkownikowi różne ekrany, gdy wywoływany
33 jest z różnymi parametrami. Jest to przypadek ogólny dla skryptów,
34 które wywołują same siebie.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc ChangeLog README
58 %{perl_vendorlib}/CGI/Screen.pm
59 %{_mandir}/man3/*
This page took 0.04996 seconds and 3 git commands to generate.