]> git.pld-linux.org Git - packages/perl-CGI-Safe.git/blob - perl-CGI-Safe.spec
5942af93bf1f9c094ab80e38e3db6ca514c4c76d
[packages/perl-CGI-Safe.git] / perl-CGI-Safe.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    CGI
7 %define         pnam    Safe
8 Summary:        CGI::Safe - safe method of using CGI.pm
9 Summary(pl.UTF-8):      CGI::Safe - bezpieczny sposób używania CGI.pm
10 Name:           perl-CGI-Safe
11 Version:        1.25
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  67e055249e96845adc8858bee0bba785
18 %{?with_tests:BuildRequires:    perl-CGI >= 2.20}
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Requires:       perl-CGI >= 2.20
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module makes running the CGI environment safer by eliminating
27 dangerous %%ENV variables and presetting certain CGI.pm globals (such
28 as disabling uploads by default and limiting POST data size).
29
30 %description -l pl.UTF-8
31 Ten moduł czyni uruchamianie środowiska CGI bezpieczniejszym poprzez
32 usuwanie niebezpiecznych zmiennych z %%ENV i ustawianie kilku
33 zmiennych globalnych CGI.pm (takich jak domyślne wyłączenie
34 przysyłania danych czy ograniczenie rozmiaru danych POST).
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/CGI/Safe.pm
60 %{_mandir}/man3/*
This page took 0.061741 seconds and 2 git commands to generate.